Jump to content
  • Announcements

    • AndalayBay

      Orphan Attachments   07/31/2018

      I have been doing some housekeeping lately and I've noticed that I had a lot of orphaned attachments. Attachments get orphaned when the PM or post is deleted without removing the attachment first. Deleting a PM or post does not delete the attachment and the file or image remain on the server. I'd like to ask all members to go through their attachments and delete any attachments you don't need anymore or those that have been orphaned. Where can I get a list of my attachments? Click on your display name in the upper right corner of the forums and pick "My Attachments" from the drop-down list. How can I tell an attachment is orphaned? If the PM has been deleted, you'll see a message like this in your attachment list: Unfortunately there is no message if the post has been deleted, so please check your old posts. We do purge old birthday threads every once in a while. Also some hosted projects have been shut down, so you may have orphaned attachments on one of those locations. Thanks!
Sign in to follow this  

Poison Kill Script Discussion

Recommended Posts

Well it is an issue for me.  I going to do a clean save and see what happens.


I did the clean save and nothing changed.  Player works in your old code, but not in my new code.


One thing I a little concerned about when I did my clean save, is how removing OBXP messed with the game.  It returned all my stats to Level 1 values.  You really should warn people that removing OBXP from your game if you no longer want to use it will pretty much ruin it or require you to use console commands to fix things.  What do you really expect people to do if they no longer want to use your mod?  

Edited by Milotek

Share this post

Link to post
Share on other sites

I think you've done something to Oblivion XP. I can't support the mod when people modify it. Removing Ob XP does not reset your stats to level 1. Your current level is maintained, although all skill progress starts at zero, of course. I know this since I've uninstalled and then reinstalled it. Lefenger has done the same with the current round of testing. He reported on Beth that he had 700 skill points to redistribute.

Share this post

Link to post
Share on other sites

Confirmed: uninstalling Oblivion XP does not reset your character to level 1. Your character remains at the level he was before you removed Ob XP, as do your skills and attributes. Your skill progress will be zero unless you trained in that skill at your current character level before uninstalling.


I don't create mods that people can't uninstall and I don't appreciate accusations to the contrary. If you are going to modify Oblivion XP, then you do so on your own.

Share this post

Link to post
Share on other sites

I didn't mean to offend you at all.  I just waned to make you aware of what happened to me.  I jumped the gun about the comment about ruining the game on uninstall.   I should have just made you aware of what happened and left it at that.  Please forgive me.


When I made my clean save it was from an unmodified version of OBXP.  I have never even made a save with a version that I modified. 


It didn't reset me to level 1 but to the level I was at when I installed OBXP.  Only the skills and attributes were set to level 1 values.  My skill progresses were like 600%.   Some higher some lower, I didn't pay that much attention. 


I will look into it and see if I did something wrong.  I don't plan on removing OBXP from my game, I like it too much. 

Share this post

Link to post
Share on other sites

That's weird. It's the opposite of what should happen. Did you uninstall after you had earned a new level, but hadn't spent your points yet? I don't think even that would cause the behaviour you experienced.


At the core, Oblivion XP sets the attributes and skills using the proper functions, so uninstalling it shouldn't reverse those values. Perhaps you should post your load order. It really sounds like you have or had something in your load order that's affecting skills because Ob XP doesn't touch skill progress at all. The only way you should see any skill progress is if you used a trainer to improve a skill in the level that you uninstalled the mod.


If you're interested in testing this, then back-up your ini file first. My favourite trick (*cough*) is to uninstall Ob XP, reinstall it and then go back to the saved game before I uninstalled it and wonder why my game is messed up. ;) It's because I forgot to restore my backup of the ini file. I have altered the levelling parameters so that I level at a slower rate, so if I forget to restore my file, I will likely be in a position to advance in level while all the progress indicators still reflect the progress at the previous rate.

Share this post

Link to post
Share on other sites

I am not sure but maybe you are misunderstanding what I am saying.  All I was doing was uninstalling OBXP from my game.  That's where things got messed up.  If I uninstall and then reinstall OBXP everything works fine.  I'm going to get you some screen shots of what Is going on.


Current load order using BOSS:


•  00 Oblivion.esm [CRC: 2FF840C5]

•  01 Francesco's Leveled Creatures-Items Mod.esm [CRC: 4CC0CFD7]

•  02 Francesco's Optional New Items Add-On.esm [CRC: 754C4DFF]

•  03 Oscuro's_Oblivion_Overhaul.esm [CRC: 40BB6CDE]

•  04 Mart's Monster Mod.esm [CRC: FA08DE55]

•  05 FCOM_Convergence.esm [CRC: 235A3B01]

•  06 Unofficial Oblivion Patch.esp [CRC: 64BCA292]

•  07 UOPS Additional Changes.esp [CRC: F222ED75]

•  08 DLCShiveringIsles.esp [CRC: 2BB84977]

•  09 Unofficial Shivering Isles Patch.esp [CRC: D5E25D6F]

•  ++ USIPS Additional Changes.esp [CRC: D01D3257]

•  0A Francesco's Creatures and Items Resources.esp [CRC: 7B1A49B1]

•  0B Francesco's Optional Chance of Stronger Bosses.esp [CRC: 19C52F4F]

•  0C Francesco's Optional Chance of Stronger Enemies.esp [CRC: 69CDAE26]

•  0D Francesco's Optional Chance of More Enemies.esp [CRC: E02591A7]

•  0E Francesco's Optional Leveled Guards.esp [CRC: 4B2B4B48]

•  ++ Francesco's Dark Seducer Weapons Patch.esp [CRC: 39CA83B1]

•  ++ FCOM_Francescos.esp [CRC: A763E334]

•  ++ FCOM_FrancescosItemsAddOn.esp [CRC: C8E156A2]

•  0F FCOM_FrancescosNamedBosses.esp [CRC: 4B999582]

•  ++ RedBag - Fog.esp [CRC: 694FDFF4]

•  10 IWR - Windows Lights Shutters - Optimised.esp [CRC: 3B43DAFA]

•  11 ChaseCameraMod.esp [CRC: C99150E1]

•  12 Maigrets Gnoll Archer.esp [CRC: 809EA864]

•  13 My Dog Rosie.esp [CRC: C04CC359]

•  14 Enhanced Economy.esp [CRC: 67026148]

•  15 Display Stats.esp [CRC: D0E2047B]

•  16 Synchronized Date and Time.esp [CRC: 18248606]

•  17 Bob's Armory Oblivion.esp [CRC: 916B1A2C]

•  18 FCOM_BobsArmory.esp [CRC: FE176DB2]

•  19 Oblivion WarCry EV.esp [CRC: 8F9765A5]

•  1A FCOM_WarCry.esp [CRC: C03178D5]

•  1B Oscuro's_Oblivion_Overhaul.esp [CRC: B266D9AC]

•  • • OMOBS_SI.esp [CRC: 6F998DD2]

•  1C FCOM_Convergence.esp [CRC: 5C891563]

•  ++ FCOM_EntropicOrderHardcore.esp [CRC: 8E79E203]

•  1D FCOM_RealSwords.esp [CRC: 132E57BE]

•  1E Mart's Monster Mod - More Wilderness Life.esp [CRC: FEA2D531]

•  ++ FCOM_SaferRoads.esp [CRC: A90C5DFC]

•  ++ FCOM_LessRats.esp [CRC: 2B2CA06F]

•  1F Mart's Monster Mod - Extra Wounding.esp [CRC: D8C0168F]

•  ++ Mart's Monster Mod - Looting NPCs & Creatures.esp [CRC: 0674FBEA]

•  ++ Mart's Monster Mod - Less Reavers.esp [CRC: CC3F03C7]

•  20 Mart's Monster Mod - Hunting & Crafting.esp [CRC: 45BC8F76]

•  21 Mart's Monster Mod - Farm Animals.esp [CRC: 7AD3E3A9]

•  • • FCOM_Archery.esp [CRC: 779D0F82]

•  22 Geomancy & Gem Dust OOO.esp [CRC: CDE74EF2]

•  23 Mart's Monster Mod - City Defences.esp [CRC: 758B61E2]

•  24 Roads of Cyrodiil.esp [CRC: A31E133F]

•  25 Ingredient Storage Shelves.esp [CRC: A1F4B115]

•  26 RefScope.esp [CRC: 09E4EE27]

•  27 SM Combat Hide.esp [CRC: 1E0914D2]

•  28 SM Bounty.esp [CRC: F8E0F54F]

•  29 Oblivion XP.esp [CRC: 63013A80]

•  2A _Ren_BeautyPack_onlyhairs.esp [CRC: 921473E5]

•  • • ROC Standard Road Record.esp [CRC: 553B24AD]

•  2B Bashed Patch, 0.esp [CRC: 33A9942A]

Share this post

Link to post
Share on other sites

Yes, I understood that. After uninstalling and verifying the results, you can re-install and go back to your saved game. I was just explaining how you can test the uninstall process, but still continue with your game afterwards. If you did that, I was also cautioning you about the effect if you forget to restore your ini file.


It's not the re-installation that fixes things. There should be nothing to fix. You should be able to uninstall Ob XP and then continue with the vanilla levelling system.


I see that you're using War Cry. Did you disable its levelling system? If not, then that will cause problems and is likely the reason you're seeing weird results when you uninstall Ob XP. Never mind. I just found out that War Cry EV doesn't have the levelling system, only New Dimension does. In that case, I don't know why the uninstallation isn't working and I just suggest you try again and see if you can repeat the issue.

Edited by AndalayBay

Share this post

Link to post
Share on other sites

I figured you understood I just wanted to make it clear for both of us.  My ini file at that time wasn't altered, but I just recently changed it to slow leveling and while doing my new uninstall/reinstall tests I forgot to make my ini changes.  I then ran a save that was real close to leveling and my XP points were nowhere near the point of leveling.  Then I remembered what you said and realized that while my XP was the same the amount needed for leveling had increased.  If you hadn't mentioned it, I probably would have freaked out and posted that something was broken!!!


Anyway, I just finished my testing and guess what, I was wrong.  After uninstalling OBXP everything was fine.  Skills and Attributes where the same as they were with OBXP installed.  Some of my Skill progresses were at unusually high percentages.  But not a big deal.  As I used those skill those percentages worked themselves out.  I have no idea what I original saw or thought, and have no excuse or theory as to what happened in my head or in reality!!!!  Either way I was just plain wrong.


I do have one issue to report.  Some of my saves now CTD when loading them with OBXP removed.   I get to the loading screen and when the progress bar starts moving, CTD.  There is no pattern as to which ones CTD, its a mix.  Some old saves crash while other old ones work fine.  Same goes for newer ones.  I have two saves that are just about half hour apart in the same dungeon and one works and the other CTDs.  When I reinstall OBXP,  the saves work just fine. 


I can't even begin to understand whats going on.  I just wanted to bring it to your attention.   As strange as this may sound to you coming from me, I'm not that concerned about it. 

Share this post

Link to post
Share on other sites

I actually had another player report something similar. In his case, the problem went away by itself. His load order has some similarities to yours. I think that the way the game loads all your mods means that some mods do kick in and affect things like levelling before they are disabled and Oblivion XP takes over. It isn't something we can do anything about, other than tell people to be patient sometimes. Not a good answer, but that's all you can do when you don't have any control over the situation and problems go away by themselves.


The CTD's are probably due to the menus. The only reliable tool for installing and uninstalling your mods is Wrye Bash's BAIN, and even that might need a poke sometimes. Oblivion XP replaces several menus, so when it's uninstalled, the original menus for the UI that you are using need to be restored. BAIN does that automatically, but OBMM or manual installations do not. Furthermore, if you have other mods that change the same menus, then those mods' menus need to be restored. Basically even if you are using BAIN, you need to take a look at your other mods and see if any of them need annealing after uninstalling Ob XP. BAIN won't restore files if it thinks that the file has been modified by something other than your BAIN packages, so it's also possible that when you uninstalled Ob XP, some menu files weren't removed. Most of the time things work fine, but if you get CTD's, then it's time to start taking a closer look at what is in your Data\Menus folder.

Share this post

Link to post
Share on other sites

I use BAIN for my installs/uninstalls.  But if it were the menus, wouldn't all my saves CTD?  As I stated, only some CTD and in no particular order.  For example, save 498-500 CTD, 496-497 don't CTD. 491-495 CTD, and so on.  Some saves are minutes apart where one CTDs and the other doesn't.   Some saves are indoors other outdoors.  All the saves I had before I installed OBXP work just fine after the uninstall.


Anyway, I am not really looking for solutions, I just found the situation interesting.  I wouldn't doubt if it was some weird conflict with one of the mods or just Oblivion being Oblivion!!!

Share this post

Link to post
Share on other sites

No, that wouldn't be menus. I've found that I can't reload my really old saves anymore. I used to be able to. That might be due to the version of MenuQue. When I first started my new game, I couldn't run MenuQue 16b. I had to stick with 16a. 16b would cause a crash when I opened a menu. Then I found that my custom potions where causing saved game bloat, so I tried upgrading to 16b. I knew that 16a had some issues. Anyway I was able to upgrade! The crashes went away.


I think with script enhancers like OBSE and MenuQue, we're pushing the engine.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this