Jump to content
  • Announcements

    • AndalayBay

      Leaving IP.Board   11/13/2017

      See full announcement here.
    • AndalayBay

      New Theme Set Up   11/14/2017

      We have a new theme created by Vincent that's now available to everyone. It has been set as the default theme, so everyone should see it when you refresh the page. If you still aren't seeing it, you can select it from the Theme drop-down at the bottom of the page. It's called Assimilation. Thanks Vincent. Awesome looking theme!
Sign in to follow this  
AndalayBay

All Natural Issues

Recommended Posts

The problem is not on the AN textures wrong or other. Textures are ok.

If textures exceeded the buffer, strange things happens to the distant LOD. The problem is not the single texture but the sum of them.

In general the problem is not AN itself, but when you use AN with OBGE or/and high resolution terrain for the distant LOD.

The skydome and the terrain distant LOD are in the same "basket" so if the buffer is out, it needs an adjustment at runtime and the result is that the textures dont match the meshes anymore: squares happen.

You solve also for example if you remove the meshes for the lod and the generated landscapelod texture folder (if any). (Dont forget to invalidate).

Share this post


Link to post
Share on other sites

Also why would something like that only mess up one single texture rather than messing them all up at random?

Share this post


Link to post
Share on other sites

Simply use Oblivion Reloaded and i do not suggest to use any texture replacement for the LOD (but you can anyway because OR solves the problem anyway).

There is no reason to use OBGE 2 or 3 anymore while the v4 is out.

OR changes the LOD shaders with a very good result with vanilla textures, you dont need to replace the textures for the LOD.

I use normally AN + OR without any problem both on my laptop with ATI (where i develop OR) and on my powerful desktop (with NVIDIA).

 

@AndalayBay: if you are interested, you can open a discussion tab on this forum for OR and i help you to support it.

Share this post


Link to post
Share on other sites

There is no reason to use OBGE 2 or 3 anymore while the v4 is out.

Probably not, but for some users OBGE 3.0 might be needed if OBGE 4.0 has a confirmed bug that's causing weird things in-game regardless what AMD/Nvidia video card you're using.

Share this post


Link to post
Share on other sites

@Leonardo: i dont want to "shield" OR because i am its developer, but there arent weird things, only some things to optimise. A good plugin/mod is tested on the vanilla game.

If something strange happens in a modded game, an accurate check is required to understand where is the "problem". A lot of mods are bad written and cause strange behaviours.

Surely also OR can be better; when i will publish the OR's code, people will see the huge difference from OBGE and if someone wants to continue my work, i will be happy of that.

I didnt fork the OBGE code, i REWROTE the entire plugin into the Oblivion's code like a patch and removing a lot of OBGE's limitations.

I think people should read better the manual. OR is not the OBGE even if the ideas are taken from the OBGE's code.

 

Anyway, this is not the place where to speak about OR. If you want to know something of this "mysterious" things, or to ask about something, you can contact me.

I know the Oblivion's code quite good and there is an explanation to everything.

 

As i wrote in a previous post @AndalayBay: if you are interested, you can open a discussion tab on this forum for OR and i help you to support it.

Edited by Alenet

Share this post


Link to post
Share on other sites

Alenet, thanks for all the information. I'll tell AN users to switch to OR then. If you'd like to start a thread for OR discussion, you're more than welcome to do so in this forum. I'm sure there are people who would have questions and would like to know more about it.

Share this post


Link to post
Share on other sites

I asked folks to equip the weather debug ring if they had the issue with sky crosses and I got this response from elecgs on Nexus:

 

 


Had crosses appear in the sky. Textures were set to large, so that wasn't the issue. Weather ID according to the debug ring: 010186e9. The mod loading in position 01 is "All Natural Base.esm". Lemme know if you need more info.

Edit: 010186e8 and 010186eb are also affected. All three weathers have the same texture for the upper layer (textures/htfweather/sky/cloud01.dds). Might be the culprit?

Edit2: It is indeed the culprit. Its mipmaps aren't right. Fixing that solves the issue (for me, at least). Download link for fixed texture: https://drive.google.com/file/d/0B_Qsg4m7KaH_Y1d0b2hkZ0JWUmc/view

 

I'll check out their fix.

Share this post


Link to post
Share on other sites

When they say the mipmaps aren't right, what do they mean? They look fine to me. Also should note that his fixed file isn't saved in a compressed format and will need to be converted to DXT5, although I see nothing different about the mipmaps.

Edited by Arthmoor

Share this post


Link to post
Share on other sites

It probably does, yes. You certainly don't want a 22MB uncompressed sky texture showing up from time to time.

Share this post


Link to post
Share on other sites

I notice that the AN files are much bigger than the originals. I was going to play with the different compression levels and see if I could figure out how Beth compressed them. Their textures aren't even a factor of 4, so I can't save them as is - I'll have to add a pixel to the height. They are 2047 instead of 2048. I know Gimp isn't as picky, so I might try that.

Share this post


Link to post
Share on other sites

When they say the mipmaps aren't right, what do they mean? They look fine to me. Also should note that his fixed file isn't saved in a compressed format and will need to be converted to DXT5, although I see nothing different about the mipmaps.

Sorry 'bout the lack of compression, I saved the texture using the default settings. Wasn't thinking about compression at the time.

 

Anyhow, here's an album comparing the first mipmap texture of the fixed and unfixed textures. Mipmaps are supposed to be downscaled copies of the texture. Notice how the unfixed mipmap is actually just the top-left quadrant of the main texture? The fixed mipmap is a downscaled copy of the main texture. Not sure why the mipmaps appear fine on your end but that's how they appear to me. This is using the texture from the latest version, unpacked from the BSA using BSAopt.

Edited by trira

Share this post


Link to post
Share on other sites

Interesting, so then there must be a display bug in the WTV (some nVidia viewer thing) that isn't displaying them the way they should be. Cause in that, the mipmaps look exactly as they should. In any case, if that's the issue, and it's resolved now, much appreciation. This has been a thing for years now :P

 

No idea how it got like that either. Must have come from the origin that way.

Share this post


Link to post
Share on other sites

Just to confirm, trira is right about the MIP maps! In fact each MIP map is a different section of the original cloud texture!! I wonder if the original creator didn't know how to generate MIP maps so he created them manually. That's the only thing I can think of.

 

So, trira, you're elecgs on Nexus? I'll credit you for the fix. Thank you!

Share this post


Link to post
Share on other sites

Thats good to know. This could be the reason why the texture buffer gets out. If the mipmap is wrong, OBGE is not able to use it correctly.

Share this post


Link to post
Share on other sites

Hi all,

 

I made a patch so that AN would have Morrowindesque-like fog settings (very close) so that it would be compatible with Sfon DeltaNovus LOD Fog mod from here http://www.nexusmods.com/oblivion/mods/25052/?

 

It would enable user to turn off distant objects thus gaining FPS.

 

uploading a patch file after conversation with AndalayBay, so it'll be here until it may be uploaded to All Natural Nexus page as an optional file or elsewhere. If it would be preferred I may even upload it as a separate download from my Nexus account.

All Natural LOD Fog patch.7z

Share this post


Link to post
Share on other sites

I have grabbed the patch and will check it out as soon as I can. I'm not really able to do any modding right now, but if the weather (no pun intended) and renovations cooperate, I might be able to take a quick look. Please feel free to check it out if you would like Morrowind-like fog settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×