Jump to content
  • Announcements

    • AndalayBay

      Linode Critical Maintenance   01/10/2018

      Phase 1 is complete. There will be a second round once Linode gets a patch. I have updated the forum thread -  please see my post here.
TheDarkListener34

Windows 10

Recommended Posts

Have you tried just installing the game? The .Net releases should be backward compatible. Quite often the game will also install the files it needs.

Share this post


Link to post
Share on other sites

The oldest .NET you can find is version 3? I’d try installing that and see if it works. I’ve played Dragon Age. In fact I played it before it was called Origins. Anyway I can check and see if I’ve got version 2 around. I have a feeling that I’ve got newer versions now though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×