Jump to content
  • Announcements

    • AndalayBay

      SSL Installed   05/29/2018

      Second IP obtained. The issues with IPv6 have also been fixed, but we can't switch to HTTPS until we switch forum software. We can't switch to HTTPS without a current license with IPS.
Sign in to follow this  
Malonn

Skyrim Special Edition

Recommended Posts

Was able to build SKSE64 project itself without the error. However, still want to establish a build order for the other projects. Googling as come up nix.SKSE64BO.thumb.jpg.47853b0cf91ec967222da791e0e330d5.jpg

The MB3073 error was resolved by defining the env. variable for Skyrim64Path:

Skyrim64Path=C:\Users\New\Desktop
and
copy "$(TargetPath)" "$(Skyrim64Path)\$(TargetFileName)"

:P Thus we'll want to have a closer look at our current proj settings. 

 

Share this post


Link to post
Share on other sites

Yes, it's right. As far as being in alphabetic order. And yes, it worked!

Here's the diff file of the proj file (imported from expired6978's Achievements but extensively modified) and the SKSE64 proj file.

projdiff.htm

Still no inkling from there what is causing the weird error above.

He links to json.cpp but can't find it anywhere. Also in the proj file there is preprocessor definition of SKSE64_EXPORTS. Does that have any significance?

 

Share this post


Link to post
Share on other sites

json.cpp could be libjson. As for the latter, that is usually used to help with symbol exports in DLLs. I'll need to take a look at the code. My Internet connection is acting up (I think they're working on the lines) but I'll get to it once they're done. :)

Share this post


Link to post
Share on other sites

Well I could get it to almost compile with the two lines commented out.

The linker doesn't like the bare looking Exports.def

LIBRARY	ACHIEVEMENTS
EXPORTS
LNK2001	unresolved external symbol ACHIEVEMENTS	achievements	C:\Users\...\source\repos\Achievements\achievements\exports.def

Tried achievements, "achievements" etc. Actually putting a matching function in from main there's more errors: 

linkerrors.jpg.b640fdc9a4467cd56eaf125ad42e9023.jpg

Looks like the renaming of the asserts never worked anyhow. :P

But what is most interesting is that in the SKSE64 "successful" compilation, exactly the same error shows!!

What wizardry have they performed to bypass it?

Edited by Schtearn

Share this post


Link to post
Share on other sites

Thanks for the offer, sure this has been explored before- it's ridiculous not being be able to sort this without issue:

Got it down to just 5 errors now:

LNK2019	unresolved external symbol "public: static void __cdecl IDebugLog::Log(enum IDebugLog::LogLevel,char const *,char *)" (?Log@IDebugLog@@SAXW4LogLevel@1@PEBDPEAD@Z) referenced in function "void __cdecl _DMESSAGE(char const *,...)" (?_DMESSAGE@@YAXPEBDZZ)
LNK2019	unresolved external symbol "public: static void __cdecl IDebugLog::OpenRelative(int,char const *)" (?OpenRelative@IDebugLog@@SAXHPEBD@Z) referenced in function skse64Plugin_Query
LNK2019	unresolved external symbol "public: __cdecl IDebugLog::IDebugLog(void)" (??0IDebugLog@@QEAA@XZ) referenced in function "void __cdecl `dynamic initializer for 'gLog''(void)" (??__EgLog@@YAXXZ)
LNK2019	unresolved external symbol "public: __cdecl IDebugLog::~IDebugLog(void)" (??1IDebugLog@@QEAA@XZ) referenced in function "void __cdecl `dynamic atexit destructor for 'gLog''(void)" (??__FgLog@@YAXXZ)
LNK2019	unresolved external symbol "void __cdecl SafeWrite32(unsigned __int64,unsigned long)" (?SafeWrite32@@YAX_KK@Z) referenced in function skse64Plugin_Load

Looks like the names are mangled. The IDebugLog class looks simple enough, though.

Quote

IDebugLog gLog;
PluginHandle    g_pluginHandle = kPluginHandle_Invalid;

The methods are being called like:

gLog.OpenRelative(CSIDL_MYDOCUMENTS, "\\My Games\\Skyrim Special Edition\\skse4\\achievements.log");

They use "$(SolutionDir)..\"- haven't seen that syntax- it's always been $(SolutionDir)\..   .

Share this post


Link to post
Share on other sites

Sure, here goes:

achievements.log

IDebugLog.h has this which is not found:

Quote

#include <cstdarg>

There's something the compiler sees wrong with the way the class method is invoked. Perhaps it can be called some other way?

Edited by Schtearn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×