Jump to content
  • Announcements

    • AndalayBay

      Leaving IP.Board   11/13/2017

      See full announcement here.
    • AndalayBay

      New Theme Set Up   11/14/2017

      We have a new theme created by Vincent that's now available to everyone. It has been set as the default theme, so everyone should see it when you refresh the page. If you still aren't seeing it, you can select it from the Theme drop-down at the bottom of the page. It's called Assimilation. Thanks Vincent. Awesome looking theme!
Sign in to follow this  
Schtearn

Sound Cards

Recommended Posts

Creative Labs and Asus are pretty much the go to brands these days. Word of caution: Vista's HAL changed how sound cards work with Windows and, since sound card drivers are notoriously slow with updates, a lot of sound cards are mostly ineffective. Basically, the drivers needed to be completely rewritten to properly offload the processing or Windows would automatically use the CPU and many cards never got the rewritten driver so most old cards were pretty much nuked entirely.

Share this post


Link to post
Share on other sites

Yeah I got the Soundblaster Zx for its support of higher impedance headphones (300 Ohm) and I love it. The higher impedance is really nice and helped with processing voice files.

Share this post


Link to post
Share on other sites

Thanks, got that feeling reading the Newegg reviews. Should get the Zx, but because of older ears there won't be much difference in audio so staying with the Z. :)
The ASUS Xonar AE may produce a better sound, but the Creative Mob always had a good rep on quality control.

Share this post


Link to post
Share on other sites

I read good stuff about the ASUS card too. I think it was a question of availability and wanting the 300 Ohms to match the headphones I wanted. One annoying thing with the Soundblaster is that you have to manually switch from speakers to headphones and vice versa. I just keep forgetting before starting up my games. :P

Share this post


Link to post
Share on other sites

Oh bum, installed the card and got distorted sound with one channel barely working at all! Fairly sure the PCI-E latency value is fine (32) but should it be set to 64?.

Not as user friendly as hoped- really wanted to swap default sound with on-board sound to test- but Creative insists on restarts all the time. :sigh:

Look's like they're stuck in a 90's driver time_warp.

Edited by Schtearn

Share this post


Link to post
Share on other sites

You've the Z, right?  You may have a bad card...

 

Do you have anything that accepts optical in?

That's an idea. Will check out if it can be done with the RX-5502. :)

 

This may sound silly (no pun intended) but have you set up your configuration in the Control Panel? A lot of people forget they have to do that and spend some time wondering why it's broken.

Gave it a go- but nada. :(

 

 

Contacted Creative. Actually ordered two cards but didn't want to try the second until - well- believe it or not the bracket that hooks the card on the chassis was too low so pliers was used to straighten it. Then gaffa taped the card on the chassis wall. Someone did not play nice with PCI slot height standards on this rig.

There's another PCI slot on the rig but believe it or not there are wires in the way! This was the downside of acquiring a factory built PC.

Back to the near-perfect on-board sound for the time being as it was buggy only on Edge browser- seamless on Chrome!

Share this post


Link to post
Share on other sites

Figured out the problem was with the existing on-board and NVIDIA sound devices. They had to be disabled. Here's a basic run-through for W10:

 

  • If card is in and you get snap/crackle/pop output:
  • Uninstall driver S/W, shut down PC
  • Go to Control panel/Advanced System Settings/Hardware Tab/Device Installation Settings/Select No (do not auto D/L Driver)
  • Remove card
  • Restart, disable all other sound devices.
  • Shut down and re-insert card without plugging in the audio jack.
  • Boot up the machine- checked devices- check other sound devices coming active again (the High Definition Audio did)  and disable them.
  • Reboot machine and plug in the audio jack to the middle socket (or optical if you have that).
  • Return to Control panel/Advanced System Settings/Hardware Tab/Device Installation Settings/Select Yes (as this is recommended by default)
  • This auto-enablez the device- get beautiful 5.1 sound (default) for everything except the muffled surround (if you only have two speakers).
  • D/L the latest driver and install. Then it's easy to switch to 2.0/2.1 sound if desired.

Worth the gaffa tape in the end (think) :)

Share this post


Link to post
Share on other sites

Were you using HDMI, then? Part of why I prefer cables that are video only is so I don't need to worry as much about that sort of thing.

 

Yeah, Nvidia's onboard sound control can be quite finicky. In my experience, half the time it doesn't even work!

Share this post


Link to post
Share on other sites

Got an HDMI connection to a second screen. It's weird because at the last bootup the disabled devices don't even show in the Playback Devices Tab. On subsequent boots they pop back in (as disabled) in which case the NVIDIA sound can be enabled in the rare case of using the dup monitor. It shouldn't be as much of an issue as the on-board sound though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×