Jump to content
  • Announcements

    • AndalayBay

      SSL Installed   05/29/2018

      Second IP obtained. The issues with IPv6 have also been fixed, but we can't switch to HTTPS until we switch forum software. We can't switch to HTTPS without a current license with IPS.
Sign in to follow this  
Darklustre

Confusing issues, need help.

Recommended Posts

At this point, I would just move your entire Data folder somewhere else, well outside the Morrowind installation directory. I would do the same thing with your saved games folder. Then I would reinstall Morrowind. Apply the MCP and verify the game works. Then install TR and verify it works.

When you reinstall Morrowind, you shouldn't install it in Program Files. Modded games usually need to write to the installation directory and Windows won't allow that. It might be messing up Mash too. Other than that, I don't know enough about Mash to say why it's not seeing your mods. Hopefully a clean install will fix that too.

Once you've got TR working, then you could start installing your other mods, but don't install a mod unless you're really going to use it. If you get a stable game with all your mods, you could try copying the last few saved game files back into the saved game directory and see if you can load up one of your old saves.

Share this post


Link to post
Share on other sites
2 hours ago, AndalayBay said:

Other than that, I don't know enough about Mash to say why it's not seeing your mods.

Why the OP can't see the mods has to do where the Installers folder is located and if it is not located as a subfolder to Morrowind then the user cannot see the mods in Mods tab in Wrye Mash.  Simple is that.

However, that depends on what version of Wrye Mash one are using.

Wrye Mash 84 always have the Installers folder as a subfolder to Morrowind.

Melchor's WMSA can be installed anywhere and the Installers folder needs to be configured via the green disk icon.

Yacoby's WMSA is basically the same as Melchor's WMSA, with one expection as it requires to be installed in the Morrowind\Mopy folder (the Installers folder is the same as Melchor's WMSA IIRC).

Sharlikran's WMSA is the latest, which I use, has the same file structure as Wrye Bash and that's like this:

  • Morrowind\Mopy
  • Morrowind Mods as a separate folder in the same folder level as Morrowind

Share this post


Link to post
Share on other sites
3 hours ago, Darklustre said:

I don't know what you mean about moving a mod up or down? Do you mean in Mash? How do I move it? I tried dragging it. I don't see any arrow keys. The only way I know to move is to redate. Can you explain please?

Okay, I'll try to explain.  Just select a mod (esp/esm) in the Mods tab then hold down the Ctrl key while using the arrow keys (beneath the Del - End - PgDn keys) up or down on your keyboard.

But remember you cannot move an esp higher than an esm or vice versa.

3 hours ago, Darklustre said:

My mods were in the right order before I reinstalled MSGO and then it clicked everything and messed up the order. I think it also locked times in Mash because I've never known to do that. And mlox redated everything but it still seems messed up. I didn't realize the game got this messed up from reinstalling MSGO :(

I think it's time for you to scrap everything and start over, I mean uninstall and reinstall Morrowind then install mods via Wrye Mash and make sure everything is either updated or fixed, plus you can launch Morrowind without having an issue.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok so I'm really frustrated. I spent the past week reinstalling the whole, dang game. Now I have a whole new set of problems and I can't understand why. The mods are all updated and there shouldn't be these problems. NoM seems to not to give penalties to the character anymore. Water Life isn't filling bottles of water, even though it's loaded before NoM. And now I'm getting all these warning texts and I don't know why. I'm hoping this is an easier fix. Mlox updated the load order. I've cleaned the saves and tried and tried. Any thoughts, guys?

Unable to locate Enchanting 'hair shirt'.
Local count for script 'NOM_master_hts' differs from saved local count. Variables will be reinitialized.
Model Load Error: Meshes\TR\x\TR_terr_WG_Cliff_03.NIF cannot load file in Meshes\TR\x\TR_terr_WG_Cliff_03.NIF.
Will use the default object Marker_Error.NIF.
Texture "Data Files\Textures\tad_rock_refl3.dds" count 3.
Texture "Textures\_land_default.tga" count 3.
Texture "Data Files\Textures\reflection.dds" count 3.
Texture "Textures\menu_thick_border_bottom_right_corner.dds" count 2.
 

_001_ Morrowind.esm
_002_ Tribunal.esm
_003_ Bloodmoon.esm
_004_ Texture Fix - Bloodmoon 1.1.esm
_005_ Morrowind Patch 1.6.5 Beta (BTB Edit).esm
_006_ Poorly Placed Object Fix 1.2.esm
_007_ Texture Fix 2.0.esm
_008_ Tamriel_Data.esm
_009_ TR_Mainland.esm
_010_ MCA.esm
_011_ abotWaterLife.esm
_012_ Infernal SummoningV1.1.esp
_013_ LCV Schedule Markers.esp
_014_ NPC LCV Schedules 03.esp
_015_ Lgnpc_SN.esp
_016_ NPC LCV Locks.esp
_017_ cloakanddagger.esp
_018_ Advanced Herbalism - TR & BM.esp
_019_ lgnpc_MaarGan.esp
_020_ Adventurers Tent.esp
_021_ The Meadow Fae.esp
_022_ Persuasion Response Expansion.esp
_023_ lgnpc_Ald'ruhn.esp
_024_ Windows Glow.esp
_025_ BE_HousesForSale.esp
_026_ EcoAdj Ingredients.esp
_027_ EcoAdjCrime.esp
_028_ EcoAdjMisc.esp
_029_ The Request Mod.esp
_030_ lgnpc_khuul.esp
_031_ LGNPC - Pelagiad.esp
_032_ Key Replacer Trib & BM.esp
_033_ EcoAdjDaedricDrops.esp
_034_ EcoAdjMerchantSkills.esp
_035_ lgnpc_HlaOad.esp
_036_ JEB_muffin_fix.esp
_037_ LGNPC - Tel Mora.esp
_038_ Windows Glow - Tribunal Eng.esp
_039_ Windows Glow - Bloodmoon Eng.esp
_040_ Illegal Dwemer Trading MW-TR.esp
_041_ WA_Signy_Signposts(!).ESP
_042_ Better Skulls.ESP
_043_ Particle Arrow Replacer.esp
_044_ Psy_VGR_Armour.esp
_045_ Vivec Outdoor Mall_v2.esp
_046_ MA_snowprincetomb_v3.esp
_047_ Jac_lightning_strike.esp
_048_ AtmosphericSoundEffects-3.0-Tribunal.esp
_049_ Balmora Expansion v1.4.esp
_050_ SirLuthor-Tools.esp
_051_ Unique Banners and Signs.esp
_052_ Better Bodies.esp
_053_ BE 1.4 -Golden Arrow fix-.esp
_054_ abotWindowsGlow.esp
_055_ Statue Replacer - Normal.esp
_056_ bones.esp
_057_ Shieldfx.esp
_058_ Book Jackets - Morrowind.esp
_059_ MTT_IV_Master.esp
_060_ Chalk30-Base.esp
_061_ Chalk30-Glow.esp
_062_ New Gnaar Mok.ESP
_063_ Book Jackets - Tribunal.esp
_064_ Book Jackets - Bloodmoon.esp
_065_ Fligg's Slave Mod.esp
_066_ NewBlood_MwTbBm1.1.esp
_067_ Neo's Unique Creatures.esp
_068_ Keyring.esp
_069_ BetterClothesForTB.esp
_070_ correctUV Ore Replacer 1.0.esp
_071_ mel_teleportPlugin_1_3.esp
_072_ Bloated Caves.esp
_073_ ExcellentMagicSounds.esp
_074_ almalexia armor.esp
_075_ Psy_UniqueDremora_T.esp
_076_ Golden Gold.esp
_077_ Animated Morrowind.esp
_078_ Adv. Herbalism Trama Complete.ESP
_079_ ASH 2.0.esp
_080_ New Voices.esp
_081_ Sleepers, Awake!.esp
_082_ guarskin_drum_replacer.esp
_083_ UniqueFinery.esp
_084_ Unique Jewelry and Accessories.esp
_085_ True_Lights_And_Darkness_1.0-NoDaylight.esp
_086_ Clean MCFC_1.0.esp
_087_ imperial chain fix.esp
_088_ UF_HortRobeF001.esp
_089_ Vurt's Grazelands Unique Trees.esp
_090_ Vurt's BC Tree Replacer II.esp
_091_ FireCliff.ESP
_092_ Vivec Expansion 2.0.esp
_093_ New Bodies - Mature.esp
_094_ Female Armor - Complete.esp
_095_ Better Weapons and Armors.esp
_096_ Clean_Chargen Revamped v2_3_2.esp
_097_ OTR_Coast_Variety.esp
_098_ STA_guides_replacer.esp
_099_ Better_Sounds.esp
_100_ Airy Fairy.ESP
_101_ Armor Chryasmere.ESP
_102_ MCA stuff.ESP
_103_ Harder NoM.ESP
_104_ NOM 3.0.esp
 

Edited by Darklustre

Share this post


Link to post
Share on other sites

Saved game cleaners aren’t magic. They can only attempt to remove references for mods you no longer have. In general, they don’t work. Your sold saves are probably corrupted and you need to start over.

Share this post


Link to post
Share on other sites
18 minutes ago, AndalayBay said:

Saved game cleaners aren’t magic. They can only attempt to remove references for mods you no longer have. In general, they don’t work. Your sold saves are probably corrupted and you need to start over.

That may apply for Oblivion and Skyrim, but that's not the case for Morrowind, because one can load a gamesave into the Enchanted Editor (EE) and edit almost whatever one wants to edit.

http://mw.modhistory.com/forum/viewtopic.php?f=9&t=6795

Share this post


Link to post
Share on other sites

It doesn't always work for Morrowind either. I had a lot of corrupted saves and they couldn't be fixed. I had to find a stable load order and stick with it. I also had to continually move my saved game files to another folder. As soon as there were more than 200 saved game files, my game would slow to a crawl and take forever to save and load.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, AndalayBay said:

It doesn't always work for Morrowind either. I had a lot of corrupted saves and they couldn't be fixed. I had to find a stable load order and stick with it. I also had to continually move my saved game files to another folder. As soon as there were more than 200 saved game files, my game would slow to a crawl and take forever to save and load.

That has nothing to do with fixing a gamesave in EE, because that's related to the game engine.  Do you know how many gamesaves I had the Saves folder before my game become unplayable?

Edited by Leonardo

Share this post


Link to post
Share on other sites
7 hours ago, AndalayBay said:

I'm not going to argue with you Leo. If you want to help Darklustre, please respond to him. I've said my piece on this issue.

Fair enough.  Him?  Darklustre is a she, I think.

Share this post


Link to post
Share on other sites
Posted (edited)

Yes Darklustre is a her. :)

I think Andalay may have been missing the point that we aren't talking about cleaning saves? I reinstalled the whole game. So I have started a new game. In fact, several times. And I still come up with these errors. Saving, exiting and coming back clears a few.  Then cleaning that save has seemed to help. But there are still warnings. I'm not sure why these are happening from a new game. Everything was installed in updated form. So that can't be it. 

In another bizarre turn, I just started another new game and have a totally different set of errors now. How could this be? Same mods!

 

Unable to locate Enchanting 'hair shirt'.
Script satyanaScript
Cast function needs to have a target ID after the spell ID on line 2?
Compiled script not saved!
==>CompileAndRun problem was found in Topic "  ---REQUEST---            "
   "Restore @magicka# concentration?  Sure."

Texture "Data Files\Textures\tx_web_enviro.dds" count 3.
Texture "Data Files\Textures\Tx_A_Silver_cuir_duke01.dds" count 3.
Texture "Textures\_land_default.tga" count 3.
Texture "Data Files\Textures\reflection.dds" count 3.
Texture "Data Files\textures\steel_ref\b_A_Steel_ankle_gm.dds" count 3.
Texture "Textures\menu_thick_border_bottom_right_corner.dds" count 2.
 

Edited by Darklustre

Share this post


Link to post
Share on other sites

The other thing I said in my process was to just install TR, test your game, then install a few mods, test your game. I don’t think you did that. I would say that you’ve got some bad mods or mods that are incompatible with TR.

It has been a long time since I’ve played Morrowind and I’ve never even heard of most of the mods you’re using, so I can’t help other than the suggestions I’ve made already.

Share this post


Link to post
Share on other sites

I don't know why you don't think I did that. I did. And I backed up each phase onto an external hard drive. Used up almost 64 gigs. Everything was working fine, as far as I could tell. It all ran. It's running now. Except now the warning text is changing from new game to new game. That doesn't seem right.

Share this post


Link to post
Share on other sites

If the errors only showed up after the last block of mods, then I would think that the problem is with one of those mods. Mods affect other mods. Unfortunately the errors you’re getting may not even have anything to do with the mod that’s reporting the error.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, Darklustre said:

Unable to locate Enchanting 'hair shirt'.

To find out what mod this error belongs to is to load your loadorder into the TESPCD and search for that error.  I bet that error belongs to MPP 1.6.5 BTB's Edit as I recall people have mention that error in the past.

_005_ Morrowind Patch 1.6.5 Beta (BTB Edit).esm

Also, the script error you got can be searched in TESPCD.

6 hours ago, Darklustre said:

Texture "Data Files\Textures\tx_web_enviro.dds" count 3.
Texture "Data Files\Textures\Tx_A_Silver_cuir_duke01.dds" count 3.
Texture "Textures\_land_default.tga" count 3.
Texture "Data Files\Textures\reflection.dds" count 3.
Texture "Data Files\textures\steel_ref\b_A_Steel_ankle_gm.dds" count 3.
Texture "Textures\menu_thick_border_bottom_right_corner.dds" count 2.

The only errors that's harmless and can be ignore are those marked with green.  The other errors are likely from MPP 1.6.5 BTB's Edit.

Texture "Data Files\Textures\Tx_A_Silver_cuir_duke01.dds" count 3.

I suggest that you uninstall MPP 1.6.5 BTB's Edit and use MPP 1.6.3 aka ThePal's last UMP.

Edited by Leonardo

Share this post


Link to post
Share on other sites

Thank you so much, Leo! I will install this program and try to learn to use it. It seems really handy. I think that MPP gets installed with MSGO. I will have to install the new one. But what do you mean I should uninstall it? Is there a function for that in Wrye? 

Thanks again.

Share this post


Link to post
Share on other sites

Yes, MPP gets installed with MGSO as MPP 1.6.5 BTB's Edit were the latest when MGSO 3.0 was released 6-8 years ago.

What I mean by uninstalling MPP is to uninstall MPP in the Installers tab aka BAIN in Wrye Mash by selecting the MPP 1.6.5 BTB's Edit archive and click on the "Uninstall" command.  Nothing else needs to be done.

After you did that install UMP 1.6.3 in Installers tab in Wrye Mash by selecting the patch63b.rar archive and click on the "Install" command.  That's all you need to do.

Of course activating a mod is necessary to do as sorting your loadorder in mlox. :)

Also, don't forget to merge the levelled lists into the Mashed Lists.esp, shown in the first picture.

Share this post


Link to post
Share on other sites

Trying again. I've reinstalled the game, and then tried Sharlikran's Mash. But I'm getting error messages and it wont open. When it tells you to choose your Morrowind directory, I choose it. Then it says there is no Morrowind.ini. However I've already played the game, and saved. It should be working just fine. 

 

 

Share this post


Link to post
Share on other sites

Open the Morrowind\Mopy\mash_default.ini file in Notepad and copy everything, but don't change anything.  Then paste it in your post.

I suspect the mash_default.ini is empty about the installation path for Morrowind.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×